STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

7
ataraxis I know my way around here Level: 24 Points: 486
Posts: 264

Location: Bavaria, Germany Printers: Ultimaker Original
Posted by
ataraxis

Posted Apr 7, 2015 - 10:20 AM • Edited  Feb 24, 2016 - 9:43 AM  

This is a collection of information on how to install the SSS-drivers (Watterott electronics).

It is based on other threads at this forum and information by watterott, reprap forums, TMC and so on...

thanks to wombl1, JonnyBischof, Dim3nsioneer, makerSpatz and everyone else

from whom I collected information

WHAT? WHY?

Most important fact at first: The SSS drivers are way more silent than the originals!

um noise cmp

And, as you can see at the following picture, the SilentStepStick-Drivers are pin compatible to the original A4988 drivers (at all important points).

a4988 pinout

The main visible difference is that the components are installed on the side that is facing toward the mainboard! That means, that the heatsink, on the other hand, is installed not directly on the IC, but on the thermal pads/vias on the other side. You have to use a non-conductve tape or sth like that to install the heatsink.

The silentstepstick drivers are based on the TMC2100, that driver-IC is able to make 16 real microsteps per full step. That is way enough in the sense of quality since a normal stepper motor cannot follow a higher resolution.

But there is one outstanding feature: microstep interpolation!

That means that if the CPU asks the TMC2100 to make one microstep, it makes instead 16 interpolated microsteps per every real microstep.

This is where the 256 microsteps come from (16*16), there is no need for the CPU to calculate 256 microsteps but the driver does it anyway. And... more microsteps lead to (way) more more silent steppers

Finally the continuous current is max. 1.2A - that is only just enough since the A4988 is also set to 1.15A (according to Ultimaker).

---

QUICK GUIDE

(if you don't want to read the entire post)

1) UMO Mainboard: Open (remove) the jumpers MS2 and MS1 everywhere you install the SSS driver

2) Drivers: Solder the pin-header, the pins should face in the same direction as the components

3) Drivers: Mount the heatsink (on the other side, where no components are!)

4) Plug the drivers in (direction: CFG1-3 on the drivers to the jumpers on the mainboard)

5) Set the current with the little screw on the drivers (start at around 0.8A and increase if necessary), see below if you don't know how that works.

6) Create a new firmware at http://marlinbuilder.robotfuzz.com/

6.1) Select your machine

6.2) Toggle "invert axis" everywhere you install the new drivers.

6.3) If you install one for the z-axis: Double the steps/mm for the z-axis

6.4) Upload the new firmware via CURA

---

NOT SO QUICK GUIDE

HARDWARE

SET THE STEPMODE

We first have to set the step mode. There are two, spreadCycle and stealthChop. We want to run the steppers in the spreadCycle mode and not at stealthChop (which is extremly silent but way to weak for 3D printers...).

That configuration is set by the CONFIG-PINS (CFGx) like the following:

  • CFG1 to GND
  • CFG2 to Open (Open means "not connected to anything" - neither low (GND) or high (VCC)).
  • There are in general two ways to reach that configuration, by the jumpers on the drivers and the mainboard-jumpers:

    cfg1 2
    Jmp Umo Mb

    Let's start with CFG1

    When you take a look at the mainboard-layout you will see a pull-down resistor at MS1 (and MS1 on the Mainboard is connected to CFG1 on the new drivers). If you remove the first Jumper on the Mainboard (MS1), the CFG1 is set to GND and we reached our first goal.

    stepper driver ultimaker breakout

    Next is CFG2

    One way to set CFG2 to Open is to desolder the little jumper on the driver-board. But that's a little inconvenient... The other way is to simply remove the second jumper (MS2) on the mainboard (thanks for the hint Tsp42).

    CFG2 is then set to Open because there is NO pull-up/pull-down resistor.

    Whats about CFG3?

    The CFG3 Jumper on the driver is by default not installed - it is therefore set to 'open' and this is what we want - nothing to do here.

    Nice to know: If CFG3 is set to open it means that the current is set through the sense-resistor (the little device that looks like a potentiometer).

    Btw... some instructions tell you to do the following:

    dontdothat

    Don't do that! It is simply not necessary and may, at worst, harm your mainboard.

    Also don't remove any pins,... It's really ugly and it is not necessary!

    If you run a RUMBA-board, follow these instructions.

    SOLDERING THE PIN-HEADER

    pins

    Solder the pin header to the PCB, please ensure that they are facing toward the side where the IC's are! I recommend to glue (just a little drop) the pinheader to the driver at first, to make sure it is rectangular while soldering. Another way is to use a breadboard (if you have one).

    MOUNT THE HEATSINK

    Use some thermal tape or anything else that is electrical but absolutely not! thermal insulating and glue the heatsink on the little thermal pads on the back of the drivers. Be sure that you don't short anything!

    INSTALL THE DRIVER

    Install the drivers to the mainboard. It's easy to determine the orientation:

    MS1-3 at the mainboard to CFG1-3 at the driver board (see picture by wombl1).

    gallery 153 2001 1498277

    SET THE CURRENT

    vref

    Measure the reference voltage (VREF) between the VREF-pin and GND (there is also a GND pad at the green LED's on the mainboard) using a volt-/multimeter. Set it by the use of the potentiometer to the current you want. Use this formula to calculate the desired VREF:

    I = (VREF * 1.77A) / 2.5V

    - or -

    VREF = (I * 2.5V) / 1.77A

    example:

    If you use the original steppers (1.15A max) the calculation should go:

    VREF = (1.15A * 2.5V) / 1.77A = 1.63V

    Anyway, start lower (at around 0.8V) and increase only if necessary, higher current lead in general to more noise and - as some users reported - a too high voltage causes overheating.

    Be cautious to not hot-wire anything when measuring the voltage (you have to turn the UM on to measure the voltage ). Thus I recommend to turn the UM off again before you adjust the sense resistor (the little thing that looks like a potentiometer).

    SOFTWARE

    INVERT THE AXIS

    The SSS and A4988 let the steppers rotate in different directions by default. If the A4988 drives it clockwise the SSS does counterclockwise and vice versa. If you simply replace the drivers without telling the firmware that something changed, your feeder will push the filament you, not in - the platform will move upwards, not downwards and so on...

    In order to fix that, you can use marlins configuration option that is called "invert axis".

    You can do so by creating a new firmware on e.g. http://marlinbuilder.robotfuzz.com/. Choose a template and toogle "invert axis" (check if unchecked by default or uncheck if checked by default) everywhere you have installed the new drivers. Build the firmware and upload via CURA.

    This is the easy way, but instead of the marlinbuilder website I really recommend to learn how to compile marlin yourself - the version on the website is not up to date!

    Another approach to invert the direction of rotation (as e.g. mariuszem prefers), is to twist the motorcables, personally I don't like it, but it is definitely okay if you do so. Take a needle and unplug the the little wire-ends from the connector, swap the first two and the last two wires (as pairs) and replug them.

    STEPS PER MM

    There is no need to adjust the steps per mm for the X any Y axis since the real microsteps didn't changed! The driver just interpolates to 256.

    But if you want to change the Z-axis too, you have to (for the z-axis only)! Just double the steps-per-mm at the firmware builder website (see above) and upload it via CURA (including the inverted axes!) or do so via the Ulticontroller: CONTROL -> MOTION -> Z-Steps/mm (double it, since it is now 16 microsteps instead of 8 - the SilentStepStick doesnt offer 8 )

    This is why it is worth the effort:

    mine

    wombl1

    makerSpatz

    and also:

    Have fun!

    118 replies
     29673 7
    Best replies 
    Sort 
    zoev89 I know my way around here Level: 30 Points: 787
    Posts: 460
    Location: Waalre, Netherlands Printers: Ultimaker Original
    Posted by
    zoev89

    Posted Apr 7, 2015 - 2:18 PM

    Thanks a lot ataraxis for compiling all the info together! You have me tempted to start implementing this upgrade although my 30mm hotend fan is by far the biggest noise contributor.

    ataraxis I know my way around here Level: 24 Points: 486
    Posts: 264
    Location: Bavaria, Germany Printers: Ultimaker Original
    Posted by
    ataraxis

    Posted Apr 7, 2015 - 2:22 PM

    Hey Zoev89, no problem - i was lost in information about different approaches spread over many websites, so I wrote it mainly for myself at first

    30mm? Haha, sweet

    drayson Feel free to ask me Level: 36 Points: 1112
    Posts: 812
    Location: Graz, Austria Printers: Ultimaker Original
    Posted by
    drayson

    Posted Apr 7, 2015 - 10:31 PM

    30mm.. Cmon thats biiig :-)

    Thank you for collecting all that info. Since more UM2 are out there, it became a bit silent on the UMO front...

    B.t.w.: 25mm - but 4 of them :-( ... :-)

    T
    tommyph1208 Feel free to ask me Level: 36 Points: 1098
    Posts: 575
    Location: Horsens, Denmark Printers: Ultimaker Original
    Posted by
    T
    tommyph1208

    Posted Apr 7, 2015 - 11:02 PM

    Im currently fitting a RUMBA board to my printer (almost done with all the wireing), and wanted to switch to the SSS drivers in the same go... Any idea if this approach works with a RUMBA board as well?

    The board does not have removeable jumpers for setting steps, but instead have an array of switches, as can be seen here:

    http://reprap.org/...STEPPER_SWITCHES.JPG

    Im guessing configuring them the same way as for the UM board should work? The board is supposed to be compatible with popolu stepstick layout so my assumption was that the pins are the same...

    ataraxis I know my way around here Level: 24 Points: 486
    Posts: 264
    Location: Bavaria, Germany Printers: Ultimaker Original
    Posted by
    ataraxis

    Posted Apr 7, 2015 - 11:16 PM • Edited  Jun 1, 2015 - 6:12 PM

    edit: removed reply - see here.

    W
    wombl1 3D printing enthusiast Level: 19 Points: 134
    Posts: 24
    Posted by
    W
    wombl1

    Posted Apr 8, 2015 - 9:40 PM

    Hey Ataraxis,

    Thanks for this .... I was thinking about this myself .... But my Garden fence is currently my project with the top Priority

    ataraxis I know my way around here Level: 24 Points: 486
    Posts: 264
    Location: Bavaria, Germany Printers: Ultimaker Original
    Posted by
    ataraxis

    Posted Apr 8, 2015 - 10:06 PM

    hey wombl, no problem, thank you for your video and pictures too.

    can you confirm the instructions? my drivers will arrive tomorrow

    W
    wombl1 3D printing enthusiast Level: 19 Points: 134
    Posts: 24
    Posted by
    W
    wombl1

    Posted Apr 9, 2015 - 8:04 AM

    Hi Ataraxis,

    Seems to be correct ..... Just had 5 Minutes left so it was more a quick glance to the important facts ...

    One more hint .... During measuring oder the reference Voltage i found it easier to pick a Grund pin from the electronics Board .... In the lower left corner is a ground hole ....

    You will See it when you try to measure it

    ataraxis I know my way around here Level: 24 Points: 486
    Posts: 264
    Location: Bavaria, Germany Printers: Ultimaker Original
    Posted by
    ataraxis

    Posted Apr 9, 2015 - 8:49 PM

    Done... Even if the video is not so impressive, it is a really big difference!!!

    (not at every speeds, but at most - especially up to around 80mm/s)

    ataraxis I know my way around here Level: 24 Points: 486
    Posts: 264
    Location: Bavaria, Germany Printers: Ultimaker Original
    Posted by
    ataraxis

    Posted Apr 10, 2015 - 12:14 AM

    btw... i first forgot to invert the z-axis, after that i forgot to invert the y-axis and, when rebuilding marlin, i forgot to double the z-steps ensure that you don't

    ataraxis I know my way around here Level: 24 Points: 486
    Posts: 264
    Location: Bavaria, Germany Printers: Ultimaker Original
    Posted by
    ataraxis

    Posted Apr 10, 2015 - 8:14 PM

    little update: did some high quality prints and didn't recognized any quality worsening. nice!

    ataraxis I know my way around here Level: 24 Points: 486
    Posts: 264
    Location: Bavaria, Germany Printers: Ultimaker Original
    Posted by
    ataraxis

    Posted Apr 11, 2015 - 3:27 PM

    DSC 0392~01 (1)
    DSC 0396~01~01

    T
    tommyph1208 Feel free to ask me Level: 36 Points: 1098
    Posts: 575
    Location: Horsens, Denmark Printers: Ultimaker Original
    Posted by
    T
    tommyph1208

    Posted Apr 14, 2015 - 7:15 PM

    Hands down, these stepper drivers are crazy!

    Printing 95 mm./s here:

    https://www.dropbox.com/...%2019.06.25.mov?dl=0

    I had already done the "remove two pins and solder over a jumper wire" approach with 4 drivers, so that is what I'm using here, and confirming that that works as well... Though the "unsolder CFG resistor" approach seems easier.

    I have the drivers dialed in at around 0.9V, mounted in a RUMBA board and running 24V on the rest of the machine ex. the 12V fans...

    ataraxis I know my way around here Level: 24 Points: 486
    Posts: 264
    Location: Bavaria, Germany Printers: Ultimaker Original
    Posted by
    ataraxis

    Posted Apr 14, 2015 - 7:19 PM

    Wow Tommy! Nice looking Ultimaker btw!!!

    T
    tommyph1208 Feel free to ask me Level: 36 Points: 1098
    Posts: 575
    Location: Horsens, Denmark Printers: Ultimaker Original
    Posted by
    T
    tommyph1208

    Posted Apr 14, 2015 - 7:36 PM

    Thx... Its taken a while to get here (and with 2 kids, each disassembly and reassembly cycle takes me forever...), but its definetely got is WAF upped a bit

    ataraxis I know my way around here Level: 24 Points: 486
    Posts: 264
    Location: Bavaria, Germany Printers: Ultimaker Original
    Posted by
    ataraxis

    Posted Apr 14, 2015 - 7:39 PM

    Haha oh hell yeah i can imagine What kind of heated bed do you use? (and what's WAF?)

    T
    tommyph1208 Feel free to ask me Level: 36 Points: 1098
    Posts: 575
    Location: Horsens, Denmark Printers: Ultimaker Original
    Posted by
    T
    tommyph1208

    Posted Apr 14, 2015 - 7:42 PM

    Its a chinese kit sold on eBay by a user here on the forum; Jason_HK, if you search the forum for that name you'll find posts about it...

    The kit comes with a relay and instructions on how to use it with the UMO, but I have mine running from a RUMBA board, and powered by a 24V Industrial PSU mounted under the printer... Hotend is 24V E3D as well

    WAF is short for Wife Acceptance Factor

    http://en.m.wikipedia.org/...fe_acceptance_factor

    ataraxis I know my way around here Level: 24 Points: 486
    Posts: 264
    Location: Bavaria, Germany Printers: Ultimaker Original
    Posted by
    ataraxis

    Posted Apr 14, 2015 - 10:07 PM

    Thanks! What kind of feeder do you use and why RUMBA and the E3D? What are the advantages of those two things?

    T
    tommyph1208 Feel free to ask me Level: 36 Points: 1098
    Posts: 575
    Location: Horsens, Denmark Printers: Ultimaker Original
    Posted by
    T
    tommyph1208

    Posted Apr 14, 2015 - 11:13 PM

    This is turning into a thread hijack

    - Its the stock feeder...

    - I switched to RUMBA to better support having a heated bed... Having spend alot of time researching how to do a heated bed upgrade for the UMO (most people use a heater mosfet to drive a relay connecting the bed and an external power supply), I realised that the standard UMO electronics kinda suck when you start doing anything but what is included in the original kit...

    The 19V system was another thing that bugged me... Its basically not compatible with anything else 3d printer related (most other systems are 12 or 24V), which means you have to get. eg. expensive 19V heaters (that is again... only if you choose to deviate from the original machine, which in all fairness is quite good).

    - The E3D I choose to be more flexible in terms of materials... It can supposedly print anything, though I have so far only printed PLA with it.... E3D also have a variety of nozzles for their hotends (from 0.25 to 0.8 mm in both brass and stainless steel), I ran a 0.6 mm. for a long while, which gave me super fast prints with little (if any) difference in quality.

    Theres been some controversy about them clogging with PLA material, but it seems to have been related to not following E3Ds assembly instructions exactly to the letter...

    You have to make sure the metal cooling fins of the cold-side of the hotend (akward sentence) gets cooled by the small fan attached to it...

    And when assembling the hotend, you have to heat it to 300 degrees and tighten the nozzle against the heatbreak while hot... Failing these steps and the hotend is useless..

    Getting them right, and I think it might be the best hotend out there...

    ataraxis I know my way around here Level: 24 Points: 486
    Posts: 264
    Location: Bavaria, Germany Printers: Ultimaker Original
    Posted by
    ataraxis

    Posted Apr 14, 2015 - 11:25 PM

    yes you are right sorry to the others and thank you for the information tommy!

    T
    tommyph1208 Feel free to ask me Level: 36 Points: 1098
    Posts: 575
    Location: Horsens, Denmark Printers: Ultimaker Original
    Posted by
    T
    tommyph1208

    Posted Apr 15, 2015 - 12:20 AM

    NP

    Thanks for gathering info in this thread, Im sure it will be helpful to alot of others as well.

    If you one day decide to take a plunge into some of the mods we discussed and want to ask anything (disclaimer: I am no expert in any of this), feel free to shoot me a PM

    (goes for anyone else stumbling across this thread)

    S
    skinnyChicken Level 1 - Starter Points: 33
    Posts: 18
    Location: calgary, Canada Printers: Ultimaker 2
    Posted by
    S
    skinnyChicken

    Posted May 3, 2015 - 5:32 AM

    has anyone put these into a UM2 yet? is it even possible?

    T
    tsp42 3D printing enthusiast Level: 12 Points: 95
    Posts: 35
    Posted by
    T
    tsp42

    Posted May 6, 2015 - 8:03 PM

    Is it really necessary to desolder the CFG2 bridge? From what I can see from the Ultimaker schematics opening the MS2 jumper will leave the CFG2 pin floating as it is not pulled to ground (only MS1 is pulled to ground).

    UMO stepper.PNG
    T
    tsp42 3D printing enthusiast Level: 12 Points: 95
    Posts: 35
    Posted by
    T
    tsp42

    Posted May 9, 2015 - 7:40 PM • Edited 10:01 PM

    Just finished installing the SilentStepStick on the X, Y and E axis. I can confirm that it is not necessary to remove the CFG2 jumper. It is sufficient to open the MS1 and MS2 jumper on the Ultimaker mainboard. I would be nice if ataraxis could update the first post, but it look like he is yet another casualty of the new forum.

    It is very impressive how much the noise is reduced with the new drivers. Certainly a plus for the WAF.

    Another thing, to get the 1,2V I had to adjust the sense resistor to 8,6 kOhm resistance between VRef and Gnd

    ataraxis I know my way around here Level: 24 Points: 486
    Posts: 264
    Location: Bavaria, Germany Printers: Ultimaker Original
    Posted by
    ataraxis

    Posted May 11, 2015 - 10:12 PM • Edited 10:31 PM

    after waiting around a month or so for a new password i'm finally back.

    and yes, you are so damn right... my fault! thank you very much for the feedback, i update it

    btw... is there anything that works on this forum after the huge "update"?

    118 replies
     29673 7
    Best replies 
    Sort 
    Support