#define DEFAULT_AXIS_STEPS_PER_UNIT - comment

D
dinac Tech Head Level: 22 Points: 361
Posts: 61

Posted by
D
dinac

Posted May 14, 2013 - 10:43 PM  

in everybody configuration.h stays this code :

<pre>
#define DEFAULT_AXIS_STEPS_PER_UNIT {78.7402,78.7402,200*8/3,760*1.1} // default steps per unit for ultimaker</pre>
This last Number 760*1.1 gives 836 steps per E

I think that beside this code it should be comment that is missing everybody:

760*1.1 is for new bolt - think it is v3 version

......but many of us that have v2 bolt and made hot bed this is not working good- it shold be 865

I think that this must be commented in code, because many that must compile new FW for HOTBED will run in problem of extruding to small amount of filament.....

1 reply
 3260
Sort 
gr5 Points: 8326
Posts: 7144

Location: Boston, United States Printers: Ultimaker 2, Ultimaker Original, Ultimaker 2 Extended, Ultimaker 2 Go
Posted by
gr5

Posted May 14, 2013 - 10:50 PM

It doesn't matter if you use cura as this is ignored. In all gcode files generated with cura it says (second line of file):

M92 E836.000000

This M92 E___ command sets the steps/mm. This line is in EVERY gcode file cura creates. To set this value, in cura, go to "file" "preferences".

1 reply
 3260
Sort