Can't update firmware

If Cura doesn’t recognize your Ultimaker Original when you want to upload firmware, there is a problem with the connection due to software or hardware failure. By following the steps described below you can easily figure out why it doesn’t work and get it working again.

Check connections and software

First of all, the connection issue could simply be caused by a physical connection failure or a problem with your computer or Cura.

  • Check if the USB cable is properly connected and if possible try another USB cable to rule out a failure of the USB cable.
  • Check if the latest version of Cura is installed on your computer.
  • Try connecting on a different computer, preferably with a different Operation System.

Electronics

The electronics of the Ultimaker Original exists of several parts (the Arduino and green main board). To rule out any of these as cause of the problem it is therefore important to test them separately.

  • Loosen the electronics from the bottom of your Ultimaker Original (the cables don't need to be unplugged).
  • Carefully take off the Arduino from the main board, so that they are separated.
  • Connect the Arduino to your computer with the USB cable and try to connect to Cura.

Caution: Never connect the power supply of your Ultimaker to the Arduino.

Is the connection being established now? If not, it means that the Arduino is causing the problem and thus a new Arduino would be needed.

When you're able to make connection while using the Arduino separately though, it means that the main board - or one of the other components connected to the main board - is causing problems. In that case, the next steps are advised:

  • Place the Arduino back onto the main board and remove all the other cables and stepper drivers (note their orientation!) from the main board.
  • Connect the electronics to your computer with the USB cable and try to connect to Cura.

If there is still no connection possible, it means that there's a bug on the main board. In this case you will need a new one.

But if you can connect when all cables and stepper drivers are unplugged, it suggests that one of the external components is causing problems. The best way to figure out which one it is, is by attaching them one at a time and testing the connection.

Once you have figured out what is causing the problem, or if you need more help, please contact our support team.

Index
Support